虫虫联盟

 找回密码
 立即注册

扫一扫,访问微社区

QQ登录

只需一步,快速开始

新浪微博登陆

只需一步, 快速开始

查看: 1239|回复: 6

易语言的置入汇编问题

[复制链接]
  • TA的每日心情
    奋斗
    2017-7-17 15:35
  • 签到天数: 2 天

    [LV.1]初来乍到

    4

    主题

    15

    帖子

    16

    积分

    新手上路

    Rank: 1

    积分
    16
    xh5510 发表于 2017-7-17 16:28:49 | 显示全部楼层 |阅读模式
    易语言置入汇编怎么写
  • TA的每日心情
    擦汗
    2018-1-24 09:41
  • 签到天数: 455 天

    [LV.9]以坛为家II

    7

    主题

    631

    帖子

    4650

    积分

    钻石会员

    Rank: 6Rank: 6

    积分
    4650
    xiexinmin 发表于 2017-7-17 17:30:47 | 显示全部楼层
    根据阿基米德原理来写!
  • TA的每日心情

    2017-12-14 10:57
  • 签到天数: 125 天

    [LV.7]常住居民III

    1

    主题

    286

    帖子

    1823

    积分

    高级会员

    Rank: 4

    积分
    1823
    恍如隔世 发表于 2017-7-17 19:57:10 | 显示全部楼层
    用键盘写比较好
  • TA的每日心情
    难过
    2018-4-14 21:00
  • 签到天数: 5 天

    [LV.2]偶尔看看I

    1

    主题

    25

    帖子

    41

    积分

    新手上路

    Rank: 1

    积分
    41
    拭去星尘. 发表于 2017-7-18 08:50:55 | 显示全部楼层
    遇见了一样的问题唉
  • TA的每日心情
    难过
    2017-12-22 19:59
  • 签到天数: 242 天

    [LV.8]以坛为家I

    24

    主题

    264

    帖子

    1750

    积分

    高级会员

    Rank: 4

    积分
    1750
    虫虫♂醉意 发表于 2017-7-21 23:42:11 | 显示全部楼层
    第一   你要用E语言的模块  
    第二   汇编要明白   

    比如一个游戏的封包喊话的汇编修改
    .版本 2

    .程序集 窗口程序集_启动窗口
    .程序集变量 进程句柄, 整数型

    .子程序 __启动窗口_创建完毕



    .子程序 发包CALL
    .参数 封包内容, 文本型
    .局部变量 内容, 字节集
    .局部变量 封包长度, 整数型
    .局部变量 发包内容地址, 整数型

    内容 = 字节集还原 (删全部空 (封包内容))
    封包长度 = 取字节集长度 (内容)
    发包内容地址 = 内存_申请内存 (封包长度, )
    内存_写字节集 (进程句柄, 发包内容地址, 内容)

    ' 比如汇编代码为
    ' 00729016  A1 4C9FC600   MOV EAX,DWORD PTR DS:[C69F4C]
    ' 0072901B  6A 02         PUSH 2
    ' 0072901D  56            PUSH ESI
    ' 0072901E  8B48 20       MOV ECX,DWORD PTR DS:[EAX+20]
    ' 00729021  E8 FA04FCFF   CALL elementc.006E9520
    asm_置代码 ()
    asm_pushad ()
    asm_mov_eax_ptr (十六到十 (“C69F4C”))
    asm_mov_ecx_ptr_eax_add (32)
    asm_push (封包长度)
    asm_push (发包内容地址)
    asm_mov_eax_常数 (十六到十 (“006E9520”))
    asm_call_eax ()
    asm_ret ()
    asm_popad ()
    asm_调用函数2 (进程句柄, asm_取代码 ())
    内存_释放内存 (发包内容地址)
    输出调试文本 (字节集转为汇编指令 (asm_取代码 ()))
  • TA的每日心情
    难过
    2017-12-22 19:59
  • 签到天数: 242 天

    [LV.8]以坛为家I

    24

    主题

    264

    帖子

    1750

    积分

    高级会员

    Rank: 4

    积分
    1750
    虫虫♂醉意 发表于 2017-7-21 23:43:23 | 显示全部楼层
    第一   你要用E语言的模块   第二   汇编要明白     比如一个游戏的封包喊话的汇编修改 .版本 2  .程序集 窗口程序集_启动窗口 .程序集变量 进程句柄, 整数型  .子程序 __启动窗口_创建完毕    .子程序 发包CALL .参数 封包内容, 文本型 .局部变量 内容, 字节集 .局部变量 封包长度, 整数型 .局部变量 发包内容地址, 整数型  内容 = 字节集还原 (删全部空 (封包内容)) 封包长度 = 取字节集长度 (内容) 发包内容地址 = 内存_申请内存 (封包长度, ) 内存_写字节集 (进程句柄, 发包内容地址, 内容)  ' 比如汇编代码为 ' 00729016  A1 4C9FC600   MOV EAX,DWORD PTR DS:[C69F4C] ' 0072901B  6A 02         PUSH 2 ' 0072901D  56            PUSH ESI ' 0072901E  8B48 20       MOV ECX,DWORD PTR DS:[EAX+20] ' 00729021  E8 FA04FCFF   CALL elementc.006E9520 asm_置代码 () asm_pushad () asm_mov_eax_ptr (十六到十 (“C69F4C”)) asm_mov_ecx_ptr_eax_add (32) asm_push (封包长度) asm_push (发包内容地址) asm_mov_eax_常数 (十六到十 (“006E9520”)) asm_call_eax () asm_ret () asm_popad () asm_调用函数2 (进程句柄, asm_取代码 ()) 内存_释放内存 (发包内容地址) 输出调试文本 (字节集转为汇编指令 (asm_取代码 ()))
  • TA的每日心情
    难过
    2017-11-30 00:09
  • 签到天数: 2 天

    [LV.1]初来乍到

    0

    主题

    11

    帖子

    29

    积分

    新手上路

    Rank: 1

    积分
    29
    762112940 发表于 2017-11-29 14:12:40 | 显示全部楼层
    我只想找个新手教程为什么全部删除了
    您需要登录后才可以回帖 登录 | 立即注册 新浪微博登陆

    本版积分规则

    QQ|手机版|小黑屋|虫虫联盟 ( 备案号:蜀ICP备15018121号-1 )

    GMT+8, 2021-9-20 03:19 , Processed in 0.646865 second(s), 33 queries .

    Powered by Discuz! X3.4 Licensed

    © 2001-2017 Comsenz Inc.

    快速回复 返回顶部 返回列表